Anmelden, um zu folgen  
Folger 0
MR

NTFS-Berechtigungen unter Windows kopieren

5 Beiträge in diesem Thema

Hallo,

ich bin so langsam am verzweifeln und weiß nicht mehr weiter. Ich hoffe nun das einer von Euch mir evtl. helfen kann.

Folgende Situation:

Ich möchte gerne per Script eine neue Verzeichnisstruktur in ein Datenverzeichnis kopieren.

Da aber nicht alle auf alle Ordner zugriff haben sollen, sind die Ordner schon jeweils mit NTFS-Berechtigungen versehen worden.

So soll es mal funktionieren:

Per Script soll aus dem Verzeichnis "Projektordner Vorlagen" der Ordner "xxx - Projektname" inkl. den Unterordnern und NTFS-Berechtigungen in den Ordner "Projekte" kopiert werden.

Lokal funktioniert es ja wunderbar mit dem Befehl XCopy, aber der Kopiervorgang soll aber über das Netzwerk stattfinden. Die Gruppe "Verwaltung" soll dieses Script ausführen und zwar immer dann wenn ein neuer Projektordner benötigt wird. Die Gruppe Verwaltung kann auch den Ordnernamen ändern, aber das ist nur nebensächlich.

Da XCopy nicht mit Netzwerkfreigaben klar kommt, versuche ich es nun mit Robocopy, aber irgendwie klappt das alles nicht so wie ich es gerne hätte.

Entweder Robokopy kopiert nichts, oder das Verzeichnis wird kopiert ohne die NTFS-Berechtigungen.

Was mache ich falsch...???

Ich habe mich nun so in das Problem verrant, dass ich vor lauter Bäumen den Wald nicht mehr sehen kann.

Ich würde mich über etwas Hilfe sehr freuen.

Vielen Dank...!!!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi, schon wieder ;-)

Welche Version von Robocopy setzt du denn ein, die von W2K, XP oder 2003???

Gerade die Parameter für die NTFS-Rechte haben sich nämlich verändert....

Bei W2K heißt es glaub ich noch /SECFIX danach gabs /SEC oder /Copy:S glaub ich....

Sag mal an, welche Version, dann kann ich nochmal nachschauen.....

ein Beispiel bei XP ist robocopy c: d: /e /w:1 /r:1 /sec

Zu der neuen Version bei 2003 hab ich das gefunden:

Das Robocopy aus dem ResoUrcekit 2003 kennt /secfix allerdings nicht mehr:

(The /TIMFIX or /SECFIX switches are no longer supported. If you have scripts that use these switches you must edit them to use /COPY: instead. /COPY:T replaces the old /TIMFIX, and /COPY:S replaces the old /SECFIX.)

Ich hoffe das hilft....

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

vielen Dank für Deine Antwort... :)

Ich habe die Version XP010 gefunden und auch installiert.

Laut Microsoft sollte diese Version Windows Server2003, WindowsXP, Windows2000 oder NT in der Version 4.0 unterstützen.

Nach meinem Wissen ist der Parameter /SECFIX gegen den Parameter /Copy:S ausgetauscht worden, aber das hast Du ja auch schon geschrieben.

Ich habe auch schon den Paramter /CopyAll ausprobiert, aber dabei bekomme ich nur die Fehlermeldung das der Klient ein erfoderliches Recht nicht besitzt. :huh:

Ich habe es einmal hinbekommen, aber dann habe ich irgendwie Murks gemacht und nun weiß ich nicht mehr wie ich das damals hinbekommen habe... bin echt am verzweifeln... :mellow:

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Nachtrag:

Ich denke es liegt an den Besitzrechten... Ich muß wohl die Gruppe als Besitzer der Ordner eintragen die diesen auch Kopieren sollen, samt NTFS-Berechtigungen, oder???

Wenn noch einer eine Idee hat, immer her damit. Ich freue mich über jeden Hinweis oder Rat.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

So, dass Problem hat sich erledigt.

Ich habe es einfach mit einem Script gelösst.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstellen Sie einen Account oder melde Sie sich an um kommentieren zu können

You need to be a member in order to leave a comment

Create an account

Registrieren Sie einen neuen Account in unserer Community. Es ist einfach!


Register a new account

Anmelden

Haben Sie bereits einen Account? Dann melden Sie sich hier an.


Jetzt Anmelden
Anmelden, um zu folgen  
Folger 0